Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 01, 2026 - 11:00 GMT
Update
The planned production database maintenance has been postponed to 01/03/2026 due to an issue encountered with test data, which is preventing the required data verification steps from being completed in the non-production environment.
Posted Feb 20, 2026 - 12:05 GMT
Scheduled
We will be performing scheduled maintenance to update internal event storage as part of ongoing improvements to platform auditability and data handling. During this window the platform will be unavailable .
Posted Feb 18, 2026 - 15:53 GMT
This scheduled maintenance affected: Mast Platform.